CocoaPods 1.1.0无法更新老项目中原有Target的解决办法

更新了Xcode8之后,重新打开好久没维护的一个项目,结果发现Alamofire4.X和iOS10以前的版本并不兼容,一狠心,不兼容9.X系列了。

安装Alamofire4.X需要CocoaPods 1.1.0,更新了pod之后我发现执行pod install的时候一直提示我的extension target需要host target,Google了各种解决办法也都没有解决,最终尝试了stackoverflow里看到的一条评论的方法:将老的target删了之后再重新添加,最终解决问题。。

应该算个比较笨的方法吧,不过也算是解决了问题。

发表评论

电子邮件地址不会被公开。 必填项已用*标注